(Status: Resolved) Connectivity Issues - DCA

Incident Report for Hyland Software Inc.

Resolved

System connectivity has been restored and is currently stable following the applied fix. Should you continue to experience any issues, please contact your first line of support for further assistance.
Posted May 15, 2026 - 19:37 UTC

Monitoring

A fix has been applied, and early signs of improvement are being observed. Hyland will continue to track the situation closely and provide updates as needed.
Posted May 15, 2026 - 17:27 UTC

Update

Hyland is continuing to investigate this issue on the highest priority. More information will be made available as Hyland's investigation continues.
Posted May 15, 2026 - 16:31 UTC

Investigating

Hyland is aware of ongoing issues within the DCA data center. More information will be provided when available.
Posted May 15, 2026 - 15:36 UTC
This incident affected: Arlington, USA (DCA).