Increased error rates have been identified

Incident Report for Hyland Software Inc.

Resolved

Hyland has remediated the issue. If you continue to have any issues please contact your first line of Hyland support.
Posted Apr 19, 2025 - 19:52 UTC

Investigating

Hyland is aware of increased error rates. Hyland is engaged and investigating this issue with the highest priority. Additional details will be provided as they become available.
Posted Apr 19, 2025 - 18:56 UTC
This incident affected: Boyers, USA (PIT).